Вопрос задан 22.04.2021 в 08:51. Предмет Информатика. Спрашивает Мамаев Максим.

Дан массив 12 чисел. Вывести числа в порядке возрастания. Написать программу Pascal ABC .

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Летов Данил.
Const n=12;
var
  a:array[1..n] of integer;
  i,j,t:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(51)-25;
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]>a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln
end.

Пример:
Исходный массив:
-6 -11 -1 -24 -15 23 14 -13 -5 3 17 -21
Отсортированный массив:
-24 -21 -15 -13 -11 -6 -5 -1 3 14 17 23
0 0
Отвечает Булатова Айна.
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(12,-99,99);
  a.Println.OrderBy(t->t).Println
end.

Пример
56 -46 -48 87 31 6 -33 -66 32 20 6 40
-66 -48 -46 -33 6 6 20 31 32 40 56 87
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример кода на Pascal ABC, который сортирует массив чисел и выводит их в порядке возрастания:

arduino
program SortArray; var arr: array[1..12] of integer; i, j, temp: integer; begin // Вводим числа в массив for i := 1 to 12 do begin write('Введите число ', i, ': '); readln(arr[i]); end; // Сортируем массив for i := 1 to 11 do begin for j := i + 1 to 12 do begin if arr[i] > arr[j] then begin temp := arr[i]; arr[i] := arr[j]; arr[j] := temp; end; end; end; // Выводим числа в порядке возрастания writeln('Числа в порядке возрастания:'); for i := 1 to 12 do begin write(arr[i], ' '); end; writeln; end.

Программа сначала запрашивает у пользователя 12 чисел и сохраняет их в массиве arr. Затем она сортирует массив с помощью двойного цикла for, сравнивая каждую пару чисел и меняя их местами, если необходимо, чтобы получить отсортированный массив. Наконец, программа выводит числа в отсортированном порядке.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос