Вопрос задан 20.04.2021 в 10:06.
Предмет Информатика.
Спрашивает Кукарцев Никита.
30 баллов. PascalABC.NET Всем известно, что в неделе 7 дней: понедельник (Monday), вторник
(Tuesday), среда (Wednesday), четверг (Thursday), пятница (Friday), суббота (Saturday) и воскресенье (Sunday).По номеру дня недели следует определить англоязычный вариант его записи.Входные данныеВходной файл INPUT.TXT содержит целое число N – номер дня недели (1 ≤ N ≤ 7).Выходные данныеВ выходной файл OUTPUT.TXT выведите ответ на задачу с заглавной буквы.Ответы на вопрос
Отвечает Пухова Диана.
Привет!
var
x:integer;
begin
readln(x);
case x of
1:writeln('Monday');
2:writeln('Tuesday');
3:writeln('Wednesday');
4:writeln('Thursday');
5:writeln('Friday');
6:writeln('Saturday');
7:writeln('Sunday');
end;
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот решение задачи на языке PascalABC.NET:
cssvar
n: integer;
begin
readln(n);
case n of
1: writeln('Monday');
2: writeln('Tuesday');
3: writeln('Wednesday');
4: writeln('Thursday');
5: writeln('Friday');
6: writeln('Saturday');
7: writeln('Sunday');
end;
end.
В этом решении мы считываем число n из входного файла, затем используем оператор case для проверки значения n и выводим соответствующий день недели на английском языке в выходной файл. Обратите внимание, что каждый вариант ответа должен начинаться с заглавной буквы, как требуется в задании.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
