 
Вопрос задан 18.04.2021 в 09:42.
Предмет Информатика.
Спрашивает Шеин Тёма.
Pascal!Даю 30 балов!!1!!!! Написать программу,помогите Дано 4-х значное число<вычислить
произведение его чисел 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Шарапов Никита.
                
                   Var a,a1,a2,a3,a4,p:integer;              
begin
write('a = '); readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
p:=a1*a2*a3*a4;
writeln('p = ',p);
end.
              
Пример:
a = 2345
p = 120
                                        begin
write('a = '); readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
p:=a1*a2*a3*a4;
writeln('p = ',p);
end.
Пример:
a = 2345
p = 120
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Благодарю за высокую оценку! Вот простая программа на языке Pascal, которая вычисляет произведение цифр введенного четырехзначного числа:
arduinoprogram MultiplicationOfDigits;
var
  num, prod, digit: integer;
begin
  write('Введите четырехзначное число: ');
  readln(num);
  prod := 1;
  while num > 0 do
  begin
    digit := num mod 10; // получаем последнюю цифру числа
    prod := prod * digit; // умножаем на произведение предыдущих цифр
    num := num div 10; // отбрасываем последнюю цифру числа
  end;
  writeln('Произведение цифр введенного числа: ', prod);
end.
Программа запрашивает у пользователя ввод четырехзначного числа, затем в цикле получает каждую цифру этого числа, умножает ее на произведение предыдущих цифр и сохраняет результат в переменной prod. По завершении цикла программа выводит на экран полученное произведение цифр.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			