Вопрос задан 15.04.2021 в 10:24. Предмет Информатика. Спрашивает Щелкунов Дима.

Помогите с программированием.Питон!!! В одномерном массиве, состоящем из n вещественных

элементов, вычислить: • сумму отрицательных элементов массива; • произведение элементов массива, расположенных между максимальным и минимальным элементами. Упорядочить элементы массива по возрастанию.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Михеев Артемий.

Объяснение:

#количество чисел - единственное число в первой строке

n = int(input())

#ввод элементов массива - все числа на второй строке

a = [float(x) for x in input().split()]

#сумма отрицательных чисел

sum_neg = sum(x for x in a if x < 0)

iMin, iMax = 0, 0

for i in range(len(a)):

   if a[iMin] > a[i]:

       iMin = i

   if a[iMax] < a[i]:

       iMax = i

product = 1

for i in range(iMin+1, iMax):

   product *= a[i]

a.sort()

print('sum = {}, product = {}'.format(sum_neg, product))

print('sorted array:', *a)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python для выполнения этих задач.

Вот пример кода, который решает вашу задачу:

python
def sum_of_negatives(arr): sum = 0 for i in arr: if i < 0: sum += i return sum def product_between_max_min(arr): if len(arr) == 0: return None max_index = arr.index(max(arr)) min_index = arr.index(min(arr)) if max_index > min_index: max_index, min_index = min_index, max_index product = 1 for i in range(max_index+1, min_index): product *= arr[i] return product def sort_array(arr): return sorted(arr) # Пример использования arr = [1, -2, 3, 4, -5, 6, 7, -8] print("Сумма отрицательных элементов массива:", sum_of_negatives(arr)) print("Произведение элементов между максимальным и минимальным элементами:", product_between_max_min(arr)) print("Отсортированный массив:", sort_array(arr))

В этом коде используются три функции:

  • sum_of_negatives вычисляет сумму отрицательных элементов массива, перебирая каждый элемент и проверяя, меньше ли он нуля.
  • product_between_max_min находит максимальный и минимальный элементы в массиве и находит произведение элементов между ними.
  • sort_array возвращает массив, отсортированный по возрастанию.

Вы можете вызвать каждую из этих функций, передав массив в качестве аргумента.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос