Вопрос задан 14.04.2021 в 15:12. Предмет Информатика. Спрашивает DELETED.

составить программу умножения первой цифры четырёхзначного числа на 10. например: при вводе числа

5389 на экран выводится число 50​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ежов Ваня.

На Pascal:

var a, b: integer;

begin

readln(a);

b:=a div 1000;

writeln(b*10);

end.

0 0
Отвечает Павлов Данил.

var a,c,rez: integer;

begin

   writeln('a = ');

   read(a);

   c := a div 1000;

   rez := c * 10;

   writeln('rez = ',rez);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая реализует умножение первой цифры четырёхзначного числа на 10 и выводит результат на экран:

python
number = int(input("Введите четырёхзначное число: ")) first_digit = number // 1000 # находим первую цифру числа result = first_digit * 10 # умножаем первую цифру на 10 print("Результат умножения первой цифры на 10:", result)

Программа сначала запрашивает у пользователя ввод четырёхзначного числа с помощью функции input, затем находит первую цифру числа, разделив его на 1000 с помощью оператора целочисленного деления //. Затем программа умножает первую цифру на 10 и выводит результат на экран с помощью функции print.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос