Вопрос задан 12.04.2021 в 05:12.
Предмет Информатика.
Спрашивает Коньшин Антон.
НАЙДИТЕ ОШИБКУ В КОДЕ! задание:Написать программу, которая бы рассчитывала значение выражения по
формуле: (ln|cos(x)|)/(ln(1+x^2). Мой код: Program formula; var x:integer; y:real; begin write('vvedute x '); readln(x); y:=(ln(abs(cos(x))))/ln(1+cos(x*x)); writeln('y=',y:5:2); end. почему то выдаёт ошибку. что не так?Ответы на вопрос
Отвечает Добряк Макс.
Program formula;
var
x:integer;
p,y:real;
begin
Write('vvedute x<>0 ->');
Readln(x);
if x=0 then Writeln('x=0 nedopustimo')
else begin
p:= abs(cos(x));
if p=0 then Writeln('ln(0) v 4islitele')
else begin
y:=ln(p)/ln(1+sqr(x*x));
Writeln('y=',y:5:2)
end
end
end.
var
x:integer;
p,y:real;
begin
Write('vvedute x<>0 ->');
Readln(x);
if x=0 then Writeln('x=0 nedopustimo')
else begin
p:= abs(cos(x));
if p=0 then Writeln('ln(0) v 4islitele')
else begin
y:=ln(p)/ln(1+sqr(x*x));
Writeln('y=',y:5:2)
end
end
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Ошибка в вашем коде связана с неправильной формулой. Формула, которую вы написали, имеет некоторые отличия от той, что была дана в задании. Вместо x^2 в знаменателе вы написали cos(x*x).
Вот исправленный код:
scssprogram formula;
var
x: integer;
y: real;
begin
write('Введите x: ');
readln(x);
y := ln(abs(cos(x))) / ln(1 + x * x);
writeln('y = ', y:5:2);
end.
Теперь формула должна работать правильно. Однако обратите внимание, что при некоторых значениях x может произойти деление на ноль, что приведет к ошибке времени выполнения программы. Если вы хотите сделать код более надежным, то можете добавить проверку на ноль в знаменателе перед выполнением вычислений.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
