Нужно решить задачу на Pascal-е: На вход программы подаются значения элементов двумерного массива
А(mxn) (m, n <= 20). Преобразовать массив, поменяв местами элементы первой строки с элементами последней, второй с предпоследней и т.д.(т.е. повернуть массив вокруг горизонтальной оси). Результат вывести на экран.Ответы на вопрос
Ответ:
program mn;
uses crt;
const m=7;n=9;
var mas:array[1..m,1..n] of Integer ;
m1, m2:array[1..n] of Integer ;
i, j, k:Integer;
begin
Randomize;
write('Исходный массив:') ;
for i:=1 to m do begin
writeln;
for j:=1 to n do begin
mas[i, j]:=random(100);
write(mas[i, j]:3) end end ;
j:=0;
repeat
for i:=1 to n do begin
m1[i]:=mas[1+j,i];
m2[i]:=mas[m-j,i];
mas[1+j,i]:=m2[i];
mas[m-j,i]:=m1[i]; end;
j:=j+1
until j>m div 2;
writeln;
write('Преобразованный массив:') ;
for i:=1 to m do begin
writeln;
for j:=1 to n do
write(mas[i, j] :3) end;
readln;
end.
Объяснение:
В разделе const задаем нужный размер исходного массива.
Код на Pascal:
arduinoprogram horizontal_flip;
const
MAX_SIZE = 20;
var
a: array[1..MAX_SIZE, 1..MAX_SIZE] of integer;
m, n, i, j, temp: integer;
begin
write('Введите количество строк (m <= ', MAX_SIZE, '): ');
readln(m);
write('Введите количество столбцов (n <= ', MAX_SIZE, '): ');
readln(n);
// Ввод значений элементов массива
for i := 1 to m do
begin
for j := 1 to n do
begin
write('Введите элемент [', i, ',', j, ']: ');
readln(a[i, j]);
end;
end;
// Перестановка элементов строк массива
for i := 1 to m div 2 do
begin
for j := 1 to n do
begin
temp := a[i, j];
a[i, j] := a[m - i + 1, j];
a[m - i + 1, j] := temp;
end;
end;
// Вывод результата
writeln('Результат:');
for i := 1 to m do
begin
for j := 1 to n do
begin
write(a[i, j], ' ');
end;
writeln;
end;
readln;
end.
Пример входных данных:
lessВведите количество строк (m <= 20): 4
Введите количество столбцов (n <= 20): 3
Введите элемент [1,1]: 1
Введите элемент [1,2]: 2
Введите элемент [1,3]: 3
Введите элемент [2,1]: 4
Введите элемент [2,2]: 5
Введите элемент [2,3]: 6
Введите элемент [3,1]: 7
Введите элемент [3,2]: 8
Введите элемент [3,3]: 9
Введите элемент [4,1]: 10
Введите элемент [4,2]: 11
Введите элемент [4,3]: 12
Пример выходных данных:
makefileРезультат:
10 11 12
7 8 9
4 5 6
1 2 3
В этом примере мы ввели двумерный массив размером 4x3 и поменяли местами его строки вокруг горизонтальной оси. Вывод программы показывает измененный массив.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
