Вопрос задан 09.04.2021 в 19:07. Предмет Информатика. Спрашивает Алексеев Руслан.

Составить программу, проверяющую, является ли заданное натуральное число совершенным, т.е. равным

сумме своих положительных делителей, кроме самого этого числа. На с++, с помощью цикла с предусловием или постусловием.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кайгородова Вика.
#include <iostream>
using namespace std;
int main(){    int i, num, sum;        sum = 0;    i = 1;    cin >> num;    while (i < num)    {        if (num % i == 0)        {            sum += i;        }        i++;    }    if (sum == num) {        cout << sum;    }    return 0;}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке C++, которая проверяет, является ли заданное натуральное число совершенным:

cpp
#include <iostream> bool isPerfectNumber(int number) { int sum = 0; for (int i = 1; i < number; i++) { if (number % i == 0) { sum += i; } } return sum == number; } int main() { int number; std::cout << "Введите натуральное число: "; std::cin >> number; if (isPerfectNumber(number)) { std::cout << number << " является совершенным числом." << std::endl; } else { std::cout << number << " не является совершенным числом." << std::endl; } return 0; }

Программа запрашивает у пользователя натуральное число, а затем вызывает функцию isPerfectNumber(), которая проверяет, является ли число совершенным. Функция isPerfectNumber() использует цикл for для нахождения суммы положительных делителей числа, и затем сравнивает эту сумму с самим числом. Если они равны, то функция возвращает true, и программа выводит сообщение о том, что число является совершенным. В противном случае, функция возвращает false, и программа выводит сообщение о том, что число не является совершенным.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос