Вопрос задан 09.04.2021 в 13:50.
Предмет Информатика.
Спрашивает Кохай Елизавета.
Напишите программу на языке паскаль вывода всех чётных чисел не кратных 4 в диапазоне от 50-70 и
найдите их количество. Пожалуйста!!Ответы на вопрос
Отвечает Чёрная Маша.
program raf105;
var a,i:integer;
begin
for i:=50 to 70 do
begin
if ((i mod 2)=0) and ((i mod 4)<>0)
then a:= a+1;
end;
writeln('Вывод: ',a);
end.
Язык программирования PascalABC
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Pascal:
vbnetprogram even_numbers;
var
i, count: integer;
begin
count := 0;
for i := 50 to 70 do
begin
if (i mod 2 = 0) and (i mod 4 <> 0) then
begin
writeln(i);
count := count + 1;
end;
end;
writeln('Количество: ', count);
end.
Эта программа использует цикл for, чтобы перебрать все числа в диапазоне от 50 до 70. Затем она проверяет, является ли текущее число четным и не кратным 4 с помощью операторов mod. Если это так, она выводит число на экран и увеличивает счетчик count на 1. По завершении цикла она выводит количество найденных чисел.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
