Вопрос задан 09.04.2021 в 06:08.
Предмет Информатика.
Спрашивает Айаған Арайлым.
Помогите составить программу на паскль:даны 2 целых числа а и в найту семму всех натуральных чисел
от а до в включительно.Ответы на вопрос
Отвечает Кузьмин Андрей.
program raf105;
var
a,b,sum,i: integer;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
for i:=a to b do
if i > 0 then
sum:= sum+i;
writeln('Сумма всех Натуральных чисел от ',a,' до ',b,' = ',sum);
end.
PascalABC 3.4.2
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal, которая находит сумму всех натуральных чисел от a до b включительно:
bashprogram SumOfNumbers;
var
a, b, sum: integer;
begin
writeln('Введите два целых числа:');
readln(a, b);
sum := 0;
for i := a to b do
begin
sum := sum + i;
end;
writeln('Сумма всех натуральных чисел от ', a, ' до ', b, ' равна ', sum);
readln;
end.
Программа запрашивает у пользователя два целых числа a и b, затем находит сумму всех натуральных чисел от a до b включительно с помощью цикла for и переменной sum. Результат выводится на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
