Вопрос задан 07.04.2021 в 17:59. Предмет Информатика. Спрашивает Гузо Ванесса.

ПОМОГИТЕ ! Напишите программу для Паскаля ! Первые две цифры в дробной части заданного

вещественного числа совпадают с записью целой части этого числа.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Никитина Кира.

####################




0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь с написанием программы на Паскале, удовлетворяющей вашим требованиям. Вот пример такой программы:

scss
program FirstTwoDecimalDigits; var num, intPart, fracPart: real; intStr, fracStr: string; begin writeln('Введите вещественное число:'); readln(num); intPart := Trunc(num); fracPart := num - intPart; Str(intPart, intStr); { преобразование целой части в строку } Str(fracPart:0.00, fracStr); { преобразование дробной части в строку } if intStr[1] = fracStr[3] then writeln('Первые две цифры дробной части совпадают с целой частью.') else writeln('Первые две цифры дробной части не совпадают с целой частью.'); readln; { ожидание нажатия клавиши перед закрытием программы } end.

Эта программа запрашивает у пользователя вещественное число, затем вычисляет его целую и дробную части с помощью функций Trunc и Fraction. Затем программа преобразует обе части в строки с помощью процедуры Str. Наконец, программа сравнивает первую цифру строки с целой частью числа с третьей цифрой строки с дробной частью числа, чтобы определить, совпадают ли первые две цифры. Результат выводится на экран.

Надеюсь, это поможет!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос