Вопрос задан 05.04.2021 в 15:43.
Предмет Информатика.
Спрашивает Феєр Еріка.
Составьте программу которая создает файл из N элементов типа integer
Ответы на вопрос
Отвечает Васин Сашка.
// PascalABC.NET 3.4.2, сборка 1797 от 22.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
WriteAllText('MyFile.txt', SeqRandom(ReadInteger('n=')).JoinIntoString)
end.
Отвечает Васин Вася.
N = input()
cifry = ['1','2','3','4','5','6','7','8','9']
all = []
for k in N:
if k in cifry:
all.append(int(k))
Например в N мы ввели "234 страницы" у нас после всех итераций цикла for в списке all должно оказаться 2,3,4
(Python)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Python, которая создает файл "integer_numbers.txt" из N случайных чисел типа integer:
pythonimport random
# Количество элементов
N = 100
# Генерируем N случайных чисел типа integer
numbers = [random.randint(1, 1000) for _ in range(N)]
# Открываем файл для записи
with open("integer_numbers.txt", "w") as file:
# Записываем каждое число в отдельной строке
for number in numbers:
file.write(str(number) + "\n")
Программа использует модуль random, чтобы сгенерировать N случайных чисел в диапазоне от 1 до 1000. Затем она открывает файл "integer_numbers.txt" для записи и записывает каждое число в отдельной строке, разделяя их символом новой строки ("\n").
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
