Вопрос задан 04.04.2021 в 18:14. Предмет Информатика. Спрашивает Bocherikova Alina.

Составить программу которая гаходит наименьшее из трёх целых чисел, введенных пользователем. Если

таких чисел несколько выдавать соответствующие сообщения. Составить на C++ СРОЧНОО ДАЮ 30 БАЛЛОВ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Амосов Артём.

#include <iostream>

using namespace std;

int main()

{

int a;

int b;

int c;

int min;

cout << "Первое число: ";

cin >> a;

cout << "Второе число: ";

cin >> b;

cout << "Третье число: ";

cin >> c;

min = a;

if (b<min){

min = b;

}

if (c<min){

min = c;

}

cout << min << endl;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на C++, которая находит наименьшее из трех целых чисел:

cpp
#include <iostream> using namespace std; int main() { int num1, num2, num3; cout << "Введите первое число: "; cin >> num1; cout << "Введите второе число: "; cin >> num2; cout << "Введите третье число: "; cin >> num3; if (num1 == num2 && num2 == num3) { cout << "Все числа равны." << endl; } else if (num1 <= num2 && num1 <= num3) { cout << "Наименьшее число: " << num1 << endl; } else if (num2 <= num1 && num2 <= num3) { cout << "Наименьшее число: " << num2 << endl; } else { cout << "Наименьшее число: " << num3 << endl; } return 0; }

Программа запрашивает у пользователя три целых числа и затем сравнивает их. Если все числа равны, программа выводит сообщение "Все числа равны". В противном случае, она находит наименьшее число и выводит его.

Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос