Вопрос задан 04.04.2021 в 08:20.
Предмет Информатика.
Спрашивает Романова Софья.
Помогите составить программу , вычисляющую сумму квадратов n чётных натуральных чисел ( сейчас
прошли циклические алгоритмы, нужна и блок-схема)Ответы на вопрос
Отвечает Белова София.
Var n,a,i:integer;
s:longint;
begin
writeln('введите количество чисел');
readln(n);
a:=0; s:=0;
writeln('введите числа');
for i:=1 to n do begin
readln(a);
if a>10 then s:=s+a*a;
end;
if s=0 then writeln('положительных чисел нет') else writeln(s);
end.
s:longint;
begin
writeln('введите количество чисел');
readln(n);
a:=0; s:=0;
writeln('введите числа');
for i:=1 to n do begin
readln(a);
if a>10 then s:=s+a*a;
end;
if s=0 then writeln('положительных чисел нет') else writeln(s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с этим! Вот программа для вычисления суммы квадратов n четных натуральных чисел:
markdown1. Запросить у пользователя число n.
2. Инициализировать переменные sum и count, оба равны 0.
3. Инициализировать переменную num, равную 2.
4. Пока count < n, выполнять следующие шаги:
- Прибавить к sum значение num * num.
- Увеличить count на 1.
- Увеличить num на 2.
5. Вывести значение переменной sum.
Это блок-схема для такой программы:
lua +-------+
+---->| Ввод n|<------+
| +-------+ |
| | |
| V |
| +-------+ |
| |sum = 0| |
| +-------+ |
| | |
| V |
| +--------+ |
+---->|count = 0| |
| +--------+ |
| | |
| V |
| +------+ |
| |num = 2| |
| +------+ |
| | |
| V |
| +-------+ |
+---->|count < n| |
+-------+ |
| N |
V Y |
+------+ |
|sum += num * num|
+------+ |
| |
V |
+--------+ |
|count += 1| |
+--------+ |
| |
V |
+------+ |
|num += 2| |
+------+ |
| |
V |
+-------+ |
|count < n| |
+-------+ |
| N |
V Y |
| |
V |
+------+ |
|Вывод sum| |
+------+
Эта программа будет запрашивать у пользователя число n и затем вычислять сумму квадратов n четных натуральных чисел, начиная с 2. Она будет прибавлять к sum значение num * num, затем увеличивать count и num на 1 и 2 соответственно. Это будет выполняться до тех пор, пока count не станет равным n. В конце программа выведет значение sum.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
