Вопрос задан 02.04.2021 в 20:42.
Предмет Информатика.
Спрашивает Фаистов Денис.
Найти в одномерном массиве А10 количество положительных элементов, кратных трём. Написать программу
на языке Паскаль.Ответы на вопрос
Отвечает Olegovish Timur.
var A:array[1..10] of integer;
i,k:integer;
begin
k:=0;
for i:=1 to 10 do
if (a[i]>0) and (a[i] mod 3=0) then k:=k+1;
writeln ('k=',k);
readln;
end.
помоему так)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, который находит количество положительных элементов, кратных трём, в одномерном массиве A с размером 10:
pascalprogram CountPositiveMultiplesOfThree; var A: array[1..10] of Integer; i, count: Integer; begin count := 0; // Заполнение массива A (можно изменить значения элементов по желанию) A[1] := 3; A[2] := 9; A[3] := -6; A[4] := 12; A[5] := 0; A[6] := 7; A[7] := 18; A[8] := -5; A[9] := 21; A[10] := 30; // Подсчет количества положительных элементов, кратных трём for i := 1 to 10 do begin if (A[i] > 0) and (A[i] mod 3 = 0) then count := count + 1; end; // Вывод результата writeln('Количество положительных элементов, кратных трём: ', count); readln; end.
Программа создает массив A размером 10 и заполняет его значениями. Затем она перебирает элементы массива в цикле и увеличивает счетчик count каждый раз, когда положительный элемент кратен трём. В конце программа выводит количество найденных элементов на экран.
Обратите внимание, что в приведенном примере значения элементов массива заданы явно. Вы можете изменить эти значения по своему усмотрению или динамически заполнить массив с клавиатуры.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
