Вопрос задан 01.04.2021 в 20:06.
Предмет Информатика.
Спрашивает Роженкова Татьяна.
Дана матрица А(nxn). Написать программу нахождения максимального элемента матрицы. решите
пожалуйста! Паскаль.Ответы на вопрос
Отвечает Бодолан Мария.
Program n1;
const n=5;
var a: array[1..n,1..n] of integer;
i,max,j: integer;
begin
randomize;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=random(100);
write(a[i,j],' ');
end;
writeln;
end;
max:=a[1,1];
for i:=1 to n do for j:=1 to n do if a[i,j]>max then max:=a[i,j];
write('max=',max);
end.
const n=5;
var a: array[1..n,1..n] of integer;
i,max,j: integer;
begin
randomize;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=random(100);
write(a[i,j],' ');
end;
writeln;
end;
max:=a[1,1];
for i:=1 to n do for j:=1 to n do if a[i,j]>max then max:=a[i,j];
write('max=',max);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая находит максимальный элемент в матрице А(nxn):
pascalprogram MaxElementMatrix; const n = 3; // Задайте значение n, которое соответствует размеру матрицы type Matrix = array[1..n, 1..n] of Integer; var A: Matrix; i, j, maxElement: Integer; begin // Ввод элементов матрицы writeln('Введите элементы матрицы A:'); for i := 1 to n do begin for j := 1 to n do begin write('A[', i, ',', j, ']: '); readln(A[i, j]); end; end; // Находим максимальный элемент maxElement := A[1, 1]; for i := 1 to n do begin for j := 1 to n do begin if A[i, j] > maxElement then maxElement := A[i, j]; end; end; // Выводим результат writeln('Максимальный элемент матрицы: ', maxElement); readln; end.
Программа запрашивает у пользователя элементы матрицы A(nxn) и затем находит максимальный элемент с помощью двойного цикла. Результат выводится на экран. Обратите внимание, что значение n задается в программе как константа n = 3, но вы можете изменить это значение, чтобы адаптировать программу для матриц другого размера.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
