Вопрос задан 01.04.2021 в 05:53.
Предмет Информатика.
Спрашивает Заведюк Станіслав.
Напишите программу которая заполняет матрицу размером 7 7 случайными числами а затем записывает в
элементы отмеченные на рисунках серым фоном число 99
Ответы на вопрос
Отвечает Бадаева Анна.
program shegor2003;
var a:array[1..7,1..7] of integer;
i,j:integer;
begin
for i:= 1 to 7 do
for j:= 1 to 7 do
a[i,j]:=random(101)-50;
writeln('Исходный массив:');
for i:= 1 to 7 do begin
for j:= 1 to 7 do
write(a[i,j]:4);
writeln;
end;
for i:= 2 to 6 do
for j:= 2 to 6 do
if i+j<=8 then
a[i,j]:=99;
writeln; writeln('Преобразованный массив:');
for i:= 1 to 7 do begin
for j:= 1 to 7 do
write(a[i,j]:4);
writeln;
end;
end.

Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
