Написать программу в Паскале Дано двузначное число. Определить: а) какая из его цифр больше:
первая или вторая; б) является ли сумма его цифр двузначным числом и чётна ли сумма его цифр.Ответы на вопрос
var
a : integer;
d1, d2, s : integer;
begin
write('введите двузначное число: ');
readln(a);
writeln('число: ', a);
if (a < 100) and (a > 9) then begin
d1 := a div 10;
d2 := a mod 10;
if d1 < d2 then writeln(d1, ' < ', d2, ' вторая цифра больше')
else if d1 > d2 then writeln(d1, ' > ', d2, ' первая цифра больше')
else writeln(d1, ' = ', d2, ' цифры равны');
s := d1+d2;
write('сумма цифр ', d1, '+', d2, '=', s);
if s < 10 then write(' однозначное, ') else write(' двузначное, ');
if s mod 2 = 0 then write('четное ') else write('не четное ');
writeln('число');
end
else writeln('это не двузначное число');
end.
Программа на языке Паскаль для решения данной задачи выглядит следующим образом:
arduinoprogram TwoDigitNumber;
var
number, firstDigit, secondDigit, digitSum: integer;
begin
// Ввод двузначного числа
write('Введите двузначное число: ');
readln(number);
// Определение первой и второй цифры числа
firstDigit := number div 10;
secondDigit := number mod 10;
// Определение того, какая цифра больше
if firstDigit > secondDigit then
writeln('Первая цифра больше второй')
else if secondDigit > firstDigit then
writeln('Вторая цифра больше первой')
else
writeln('Первая и вторая цифры равны');
// Определение суммы цифр числа
digitSum := firstDigit + secondDigit;
// Проверка, является ли сумма цифр двузначным числом и четной ли она
if digitSum > 9 then
begin
if digitSum mod 2 = 0 then
writeln('Сумма цифр двузначна и четна')
else
writeln('Сумма цифр двузначна, но нечетна');
end
else
writeln('Сумма цифр однозначна');
readln;
end.
Программа сначала запрашивает у пользователя двузначное число и определяет первую и вторую цифры числа. Затем она проверяет, какая из цифр больше, и выводит соответствующее сообщение.
Далее программа определяет сумму цифр числа и проверяет, является ли она двузначным числом. Если да, то программа проверяет, является ли сумма четной, и выводит соответствующее сообщение. Если сумма цифр однозначна, программа выводит сообщение об этом.
Например, если пользователь введет число 63, программа выведет следующий результат:
Введите двузначное число: 63 Вторая цифра больше первой Сумма цифр двузначна и нечетна
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
