Задание: составить программу, в которой заменить все буквы а буквой о. (в pascal) (тема:
двумерные массивы)Ответы на вопрос
program raf105;
var a:array[1..30,1..20] of string;
i,j,o:integer;
s:string;
begin
for i:=1 to 30 do
for j:=1 to 20 do
a[i,j]:= '';
writeln('Вводите слова по очереди');
writeln('Чтобы закончить введите 0');
repeat
readln(s);
if s <> '0'
then
begin
o:= o+1;
for i:=1 to length(s) do
a[o,i]:= s[i];
end;
until s = '0';
writeln;
writeln('Вывод:');
for i:=1 to o do
begin
for j:=1 to 20 do
if a[i,j] = 'а'
then a[i,j]:= 'о';
for j:=1 to 20 do
if j <> 1
then
begin
a[i,1]:= a[i,1] + a[i,j];
a[i,j]:= '';
end;
writeln(a[i,1]);
end;
end.
Вот пример программы на Pascal, которая заменяет все буквы "a" на букву "o" в двумерном массиве символов:
vbnetprogram ReplaceAWithO;
const
ROWS = 3; // количество строк в массиве
COLS = 5; // количество столбцов в массиве
var
arr: array[1..ROWS, 1..COLS] of Char;
i, j: Integer;
begin
// Заполнение массива случайными символами
for i := 1 to ROWS do
for j := 1 to COLS do
arr[i, j] := Chr(Random(26) + 97);
// Вывод исходного массива
writeln('Исходный массив:');
for i := 1 to ROWS do
begin
for j := 1 to COLS do
write(arr[i, j], ' ');
writeln;
end;
// Замена буквы "a" на букву "o"
for i := 1 to ROWS do
for j := 1 to COLS do
if arr[i, j] = 'a' then
arr[i, j] := 'o';
// Вывод измененного массива
writeln('Измененный массив:');
for i := 1 to ROWS do
begin
for j := 1 to COLS do
write(arr[i, j], ' ');
writeln;
end;
readln;
end.
Программа сначала заполняет двумерный массив arr случайными символами в диапазоне от 'a' до 'z'. Затем она выводит исходный массив на экран. Далее программа заменяет все буквы 'a' на 'o' в массиве arr. Наконец, она выводит измененный массив на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
