Вопрос задан 29.03.2021 в 05:03.
Предмет Информатика.
Спрашивает Сай Анастасия.
Паскаль Написать программу движения по экрану прямоугольника со сторонами 15 и 10 точек по
вертекали сверху внизОтветы на вопрос
Отвечает Байрозян Алекс.
Program rec;
uses graphabc;
var x:integer = 1280;
y:integer = 720;
y2:integer = 1;
y3:integer = 15;
begin
setwindowsize(x,y);
setpencolor(clblack);
setpenwidth(3);
Rectangle(x div 2,y2,x div 2 + 10, y3);
while(y3<710) do
begin
y2+=1;
y3+=1;
Rectangle(x div 2,y2,x div 2 + 10, y3);
FillRectangle(x div 2 -1,y2-3,x div 2 + 11, y2-1);
sleep(50);
end;
end.
uses graphabc;
var x:integer = 1280;
y:integer = 720;
y2:integer = 1;
y3:integer = 15;
begin
setwindowsize(x,y);
setpencolor(clblack);
setpenwidth(3);
Rectangle(x div 2,y2,x div 2 + 10, y3);
while(y3<710) do
begin
y2+=1;
y3+=1;
Rectangle(x div 2,y2,x div 2 + 10, y3);
FillRectangle(x div 2 -1,y2-3,x div 2 + 11, y2-1);
sleep(50);
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример кода на языке Pascal, который реализует движение прямоугольника вниз по экрану:
scssprogram rectangle_movement;
uses crt;
const
width = 15; // ширина прямоугольника
height = 10; // высота прямоугольника
speed = 1; // скорость движения прямоугольника
var
x, y: integer;
begin
// начальное положение прямоугольника
x := 20;
y := 1;
// отображаем прямоугольник на экране
gotoxy(x, y);
write('***************');
gotoxy(x, y+1);
write('* *');
gotoxy(x, y+2);
write('* *');
gotoxy(x, y+3);
write('* *');
gotoxy(x, y+4);
write('* *');
gotoxy(x, y+5);
write('***************');
// двигаем прямоугольник вниз до тех пор, пока он не достигнет конца экрана
while y < 25 do
begin
// стираем прямоугольник с текущей позиции
gotoxy(x, y);
write(' ');
gotoxy(x, y+1);
write(' ');
gotoxy(x, y+2);
write(' ');
gotoxy(x, y+3);
write(' ');
gotoxy(x, y+4);
write(' ');
gotoxy(x, y+5);
write(' ');
// перемещаем прямоугольник вниз на заданную скорость
y := y + speed;
// отображаем прямоугольник на новой позиции
gotoxy(x, y);
write('***************');
gotoxy(x, y+1);
write('* *');
gotoxy(x, y+2);
write('* *');
gotoxy(x, y+3);
write('* *');
gotoxy(x, y+4);
write('* *');
gotoxy(x, y+5);
write('***************');
// задержка для создания эффекта движения
delay(100);
end;
// сообщаем о завершении программы
gotoxy(1, 25);
writeln('Done.');
end.
В данной программе используется библиотека crt для работы с экраном. Программа начинается с установки начальной позиции прямоугольника (координаты x и y). Затем прямоугольник отображается на экране с помощью последовательности команд gotoxy и write.
Далее запускается цикл, в котором прямоугольник перемещается вниз до тех пор, пока его нижний край не достигнет конца экрана (координата y равна 25). Внутри цик
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
