
Вопрос задан 28.03.2021 в 22:26.
Предмет Информатика.
Спрашивает Вайсман Елена.
Помогите составить программу на языке Паскаль с помощью Random дано a[i]∈[-13,8] Найти
произведение нечетных отрицательных чисел n=5

Ответы на вопрос

Отвечает Рейзер Эрика.
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(5,-13,8).Println.Where(t->(t<0) and t.IsOdd).ToArray;
if a.Count>0 then a.Aggregate(1,(i,j)->i*j).Println
else Writeln(0)
end.
Пример
-2 -6 -6 -7 -13
91
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(5,-13,8).Println.Where(t->(t<0) and t.IsOdd).ToArray;
if a.Count>0 then a.Aggregate(1,(i,j)->i*j).Println
else Writeln(0)
end.
Пример
-2 -6 -6 -7 -13
91



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль для нахождения произведения пяти нечетных отрицательных чисел из массива a:
vbnetprogram odd_negatives_multiplication;
uses
crt;
const
n = 20; {размер массива}
min_val = -13; {минимальное значение элементов массива}
max_val = 8; {максимальное значение элементов массива}
target_count = 5; {количество нечетных отрицательных чисел}
var
a: array[1..n] of integer; {массив}
i, j, count: integer; {счетчики}
product: integer; {произведение}
begin
randomize; {инициализация генератора случайных чисел}
{заполнение массива случайными значениями}
for i := 1 to n do
a[i] := random(max_val - min_val + 1) + min_val;
count := 0;
product := 1;
{поиск пяти нечетных отрицательных чисел и вычисление их произведения}
for i := 1 to n do
begin
if (a[i] < 0) and (a[i] mod 2 <> 0) then {если число отрицательное и нечетное}
begin
Inc(count); {увеличиваем счетчик найденных чисел}
if count <= target_count then {если найдено не более 5 чисел}
product := product * a[i] {умножаем число на текущее произведение}
else
break; {если найдено более 5 чисел, выходим из цикла}
end;
end;
{вывод результатов}
writeln('Массив a:');
for i := 1 to n do
write(a[i]:4);
writeln;
writeln;
if count < target_count then
writeln('Найдено менее 5 нечетных отрицательных чисел в массиве')
else
writeln('Произведение 5 нечетных отрицательных чисел равно ', product);
readkey; {ожидание нажатия клавиши}
end.
Пример работы программы:
yamlМассив a:
-2 -2 -3 2 -7 -5 5 -2 -3 8
3 5 -7 -7 -3 -5 -5 -1 -5 3
Произведение 5 нечетных отрицательных чисел равно 1225


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili