Нужна программа в паскале ABC Задача: Дан одномерный массив C(N). Удалить элементы одномерного
массива, которые больше среднего арифметического значения. Выведите на печать преобразованный массив и число его элементов.Ответы на вопрос
program fantscrin;
var a,c: array [1..1000] of integer;
i,n,s,j:integer;
Begin
write('N = '); readln(n);
s:=0;
for i:=1 to n do
begin
write('c[',i,'] = '); readln(c[i]);
s:=s+c[i];
end;
writeln('S = ', s);
j:=0;
for i:=1 to n do
if c[i] > s / n then
begin
j:= j + 1;
a[j]:= c[i];
end;
for i:=1 to j do
write(a[i], ' ')
End.
Конечно, я могу написать программу на языке Паскаль ABC для решения данной задачи. Ниже приведен код, который решает данную задачу:
vbnetprogram delete_array_elements;
const
N = 10; {размер массива}
var
C: array[1..N] of integer; {массив}
i, sum, average, count: integer;
begin
{ввод элементов массива}
writeln('Введите элементы массива C:');
for i := 1 to N do
readln(C[i]);
{вычисление суммы элементов массива}
sum := 0;
for i := 1 to N do
sum := sum + C[i];
{вычисление среднего арифметического}
average := sum div N;
{удаление элементов, которые больше среднего арифметического}
count := 0;
for i := 1 to N do
if C[i] <= average then
begin
count := count + 1;
C[count] := C[i];
end;
{вывод преобразованного массива и числа его элементов}
writeln('Преобразованный массив C:');
for i := 1 to count do
write(C[i], ' ');
writeln;
writeln('Число элементов в преобразованном массиве: ', count);
end.
Программа запрашивает элементы массива C, вычисляет среднее арифметическое значение, удаляет элементы, которые больше среднего арифметического значения, выводит преобразованный массив и число его элементов. Я надеюсь, что этот код поможет вам решить данную задачу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
