Вопрос задан 23.03.2021 в 23:36.
Предмет Информатика.
Спрашивает Бухарбаев Марат.
Паскаль. С клавиатуры вводится 10 целых чисел. Найти сумму тех из них, которые оканчивается на 3.
ПОМОГИТЕ ПОЖАЛУЙСТА ССРРРОООЧЧНННООО!!!!!!!Ответы на вопрос
Отвечает Колов Муса.
Program n1;
var a,sum,i: integer;
begin
sum:=0;
for i:=1 to 10 do
begin
readln(a);
if a mod 10=3 then sum:=sum+a;
end;
write(sum);
end.
var a,sum,i: integer;
begin
sum:=0;
for i:=1 to 10 do
begin
readln(a);
if a mod 10=3 then sum:=sum+a;
end;
write(sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на языке Паскаль, которая найдет сумму чисел, оканчивающихся на 3. Вот пример такой программы:
pascalprogram SumOfNumbers; var i, number, sum: integer; begin sum := 0; writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin readln(number); if number mod 10 = 3 then sum := sum + number; end; writeln('Сумма чисел, оканчивающихся на 3:', sum); readln; end.
Программа просит вас ввести 10 целых чисел с клавиатуры. Затем она проверяет каждое число на остаток от деления на 10 и если остаток равен 3, то число добавляется к общей сумме. В конце программа выводит сумму чисел, оканчивающихся на 3.
Надеюсь, это помогло! Если у вас есть еще вопросы, пожалуйста, дайте знать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
