
Составить программу на языке С. Как можно проще, используя массив. Задание: Дана матрица C
размером 3х4, составить программу для подсчета количества четных элементов в каждой строке матрицы с их запоминанием.

Ответы на вопрос

int[,] A = new int[3,4]; //любое заполнение А
int[] evens = new int[3]; //массив чётных чисел в каждой строке
for (int i = 0; i < 3; i++)
for (int j = 0; j < 4; j++)
if (A[i, j] % 2 == 0)
evens[i]++;



Конечно! Вот простая программа на языке C, которая использует массив для подсчета количества четных элементов в каждой строке матрицы:
c#include <stdio.h>
#define ROWS 3
#define COLS 4
int main() {
int matrix[ROWS][COLS] = {
{1, 2, 3, 4},
{5, 6, 7, 8},
{9, 10, 11, 12}
};
int evenCount[ROWS] = {0}; // Инициализируем массив для хранения количества четных элементов
for (int i = 0; i < ROWS; i++) {
for (int j = 0; j < COLS; j++) {
if (matrix[i][j] % 2 == 0) {
evenCount[i]++; // Увеличиваем счетчик четных элементов для текущей строки
}
}
}
// Выводим результаты подсчета
for (int i = 0; i < ROWS; i++) {
printf("В строке %d количество четных элементов: %d\n", i + 1, evenCount[i]);
}
return 0;
}
В этой программе мы используем двумерный массив matrix
размером 3x4 для представления матрицы C. Мы также создаем одномерный массив evenCount
размером 3, чтобы хранить количество четных элементов в каждой строке.
Затем мы используем два вложенных цикла for
для перебора всех элементов матрицы. Если элемент является четным числом, мы увеличиваем счетчик evenCount
для соответствующей строки.
Наконец, мы выводим результаты подсчета с помощью еще одного цикла for
.
Программа выводит количество четных элементов для каждой строки матрицы C.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili