Составить программу в Паскале , используя оператор цикла с предусловием. Из интервала [0;5) вывести
на печать нечётные числа, каждое с новой строки.Ответы на вопрос
program raf105;
var i: integer;
begin
i:= 0;
while i < 5 do
begin
if (i mod 2 <> 0)
then writeln(i);
i+= 1;
end;
end.
Pascal ABC 3.4.2.
Вот пример программы на Паскале, использующей оператор цикла с предусловием для вывода нечетных чисел из интервала [0;5) на печать:
pascalprogram PrintOddNumbers; var i: integer; begin i := 0; while i < 5 do begin if i mod 2 <> 0 then writeln(i); i := i + 1; end; end.
Эта программа объявляет переменную i типа integer и инициализирует ее значением 0. Затем она входит в цикл while, который продолжается, пока i меньше 5.
Внутри цикла проверяется, является ли текущее значение i нечетным. Если это так (т.е., i mod 2 <> 0), то оно выводится на печать с помощью процедуры writeln.
После вывода числа значение i увеличивается на 1 с помощью оператора i := i + 1, и цикл повторяется. Таким образом, программа выводит на печать все нечетные числа из интервала [0;5), каждое на новой строке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
