Вопрос задан 21.03.2021 в 07:04.
Предмет Информатика.
Спрашивает Кузьмин Сергей.
Помогите с Паскалем ABS. 1 дано пятизначное число. определить сумму второй и пятой цифры. 2 дано
пятизначное число. Определить сумму второй и четвёртой цифрой. 3 написать программу в которой подсчитывается количество чётных чисел среди трёх, введёных с клавиатурыОтветы на вопрос
Отвечает Иванов Иван.
№2.
var a,b: integer;
beginreadln(a);
b:=a;
a:= (a div 10) mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
№1.
var a,b: integer;
beginreadln(a);
b:=a;
a:= a mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
var a,b: integer;
beginreadln(a);
b:=a;
a:= (a div 10) mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
№1.
var a,b: integer;
beginreadln(a);
b:=a;
a:= a mod 10;
b:= (b div 1000) mod 10;
writeln(b+a);
end.
Отвечает Буланова Анастасия.
№ 1-2
var x, t, f, l, sum, sum2: integer;
begin
write('Введите x: ');
readln(x);
if ( x < 10000 ) OR ( x > 99999 ) then
writeln('Ошибка. Число не пятизначное!')
else
begin
l := x mod 10;
t := (x div 1000 mod 10);
sum := l + t;
f := (x div 10 mod 10);
sum2 := t + f;
writeln('Сумма второй и последней цифры: ', sum);
writeln('Сумма второй и четвертой цифры: ', sum2);
end;
end.
№3
var a, b, c, rez: integer;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
rez := 0;
if a mod 2 = 0 then inc(rez);
if b mod 2 = 0 then inc(rez);
if c mod 2 = 0 then inc(rez);
writeln('Количество четных чисел: ', rez);
end.
var x, t, f, l, sum, sum2: integer;
begin
write('Введите x: ');
readln(x);
if ( x < 10000 ) OR ( x > 99999 ) then
writeln('Ошибка. Число не пятизначное!')
else
begin
l := x mod 10;
t := (x div 1000 mod 10);
sum := l + t;
f := (x div 10 mod 10);
sum2 := t + f;
writeln('Сумма второй и последней цифры: ', sum);
writeln('Сумма второй и четвертой цифры: ', sum2);
end;
end.
№3
var a, b, c, rez: integer;
begin
write('Введите первое число: ');
readln(a);
write('Введите второе число: ');
readln(b);
write('Введите третье число: ');
readln(c);
rez := 0;
if a mod 2 = 0 then inc(rez);
if b mod 2 = 0 then inc(rez);
if c mod 2 = 0 then inc(rez);
writeln('Количество четных чисел: ', rez);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с этими задачами на языке Паскаль. Вот решение каждой из них:
- Дано пятизначное число. Определить сумму второй и пятой цифр.
pascalprogram SumOfSecondAndFifthDigits; var number, digit2, digit5, sum: Integer; begin Write('Введите пятизначное число: '); ReadLn(number); digit2 := (number div 1000) mod 10; digit5 := number mod 10; sum := digit2 + digit5; WriteLn('Сумма второй и пятой цифр: ', sum); end.
- Дано пятизначное число. Определить сумму второй и четвёртой цифры.
pascalprogram SumOfSecondAndFourthDigits; var number, digit2, digit4, sum: Integer; begin Write('Введите пятизначное число: '); ReadLn(number); digit2 := (number div 10000) mod 10; digit4 := (number div 10) mod 10; sum := digit2 + digit4; WriteLn('Сумма второй и четвёртой цифр: ', sum); end.
- Написать программу, в которой подсчитывается количество чётных чисел среди трёх, введённых с клавиатуры.
pascalprogram CountEvenNumbers; var num1, num2, num3, count: Integer; begin count := 0; WriteLn('Введите три числа:'); Write('Число 1: '); ReadLn(num1); Write('Число 2: '); ReadLn(num2); Write('Число 3: '); ReadLn(num3); if num1 mod 2 = 0 then Inc(count); if num2 mod 2 = 0 then Inc(count); if num3 mod 2 = 0 then Inc(count); WriteLn('Количество чётных чисел: ', count); end.
Надеюсь, эти программы помогут вам решить ваши задачи! Если у вас возникнут ещё вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
