Вопрос задан 19.03.2021 в 22:49.
Предмет Информатика.
Спрашивает Бородина Надюшка.
Написать программу паскале:Даны два числа. Увеличить каждое из них в два раза, если их сумма
четная, в противном случае увеличить в два раза только первое число.Ответы на вопрос
Отвечает Романов Даниил.
Var x,y:longint;
begin
readln(x,y);
if (x+y) mod 2=0 then writeln(2*x,' ',2*y)
else
writeln(2*x,' ',y);
readln;
end.
begin
readln(x,y);
if (x+y) mod 2=0 then writeln(2*x,' ',2*y)
else
writeln(2*x,' ',y);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, которая реализует указанные условия:
pascalprogram IncreaseNumbers; var number1, number2, sum: integer; begin writeln('Введите первое число: '); readln(number1); writeln('Введите второе число: '); readln(number2); sum := number1 + number2; if sum mod 2 = 0 then begin number1 := number1 * 2; number2 := number2 * 2; end else begin number1 := number1 * 2; end; writeln('Результат:'); writeln('Первое число: ', number1); writeln('Второе число: ', number2); readln; end.
Пользователю будет предложено ввести два числа. Затем программа проверит, является ли сумма этих чисел четной. Если сумма четная, то оба числа будут увеличены в два раза. В противном случае будет увеличено только первое число. Результат будет выведен на экран.
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 14
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
