Задача на Паскале продолжительность фильма 3416 секунд напишите программу которая вычислит сколько
это полных минутОтветы на вопрос
Ответ:
VAR seconds, minutes :Integer;
BEGIN
seconds := 3416;
minutes := seconds DIV 60;
WriteLn(minutes);
ReadLn
END.
Объяснение:
Первая строка задаёт целочисленные переменные.
BEGIN и END - начало и конец программы соответственно.
3 строка - присвоение переменной seconds значения 3416.
4 строка - целочисленное деление, т. е. деление на 60 без остатка.
WriteLn печатает результат 56, т. е. 56 полных минут.
ReadLn не даёт программе закрыться, пока пользователь этого не захочет.
Вот пример программы на языке Pascal, которая вычисляет количество полных минут в заданной продолжительности фильма в секундах:
pascalprogram DurationConverter; var durationInSeconds, durationInMinutes: Integer; begin // Ввод продолжительности фильма в секундах writeln('Введите продолжительность фильма в секундах:'); readln(durationInSeconds); // Вычисление количества полных минут durationInMinutes := durationInSeconds div 60; // Вывод результата writeln('Продолжительность фильма в полных минутах:', durationInMinutes); end.
Программа запрашивает у пользователя продолжительность фильма в секундах и затем делит это число на 60, чтобы получить количество полных минут. Результат выводится на экран. Если вам нужно изменить продолжительность фильма, вы можете изменить значение переменной durationInSeconds на нужное число.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
