Вопрос задан 14.03.2021 в 01:57.
Предмет Информатика.
Спрашивает Кагиров Арсен.
Напишите программу вычисляющую и выводящую n первых членов последовательности Фибоначчи. Нужна в
Паскале. Помогите, пожалуйста, нужно срочно.Ответы на вопрос
Отвечает Баязитов Артем.
алг
нач
цел а,б,в,н,с
вывод "Печать n первых членов последовательности Фибоначчи"
вывод нс, "Введите n: "
ввод н
а := 1
б := 1
нц для с от 1 до н
вывод а, нс
в := а + б
а := б
б := в
кц
кон

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая вычисляет и выводит первые n членов последовательности Фибоначчи:
pascalprogram FibonacciSequence; var n, i: Integer; fib1, fib2, fib: Integer; begin Write('Введите количество членов последовательности: '); ReadLn(n); if n <= 0 then begin WriteLn('Количество членов должно быть положительным числом.'); Exit; end; fib1 := 0; fib2 := 1; WriteLn('Первые ', n, ' членов последовательности Фибоначчи:'); WriteLn(fib1); WriteLn(fib2); for i := 3 to n do begin fib := fib1 + fib2; WriteLn(fib); fib1 := fib2; fib2 := fib; end; end.
Программа сначала запрашивает у пользователя количество членов последовательности, а затем с помощью цикла for вычисляет и выводит соответствующие значения. Первые два члена (fib1 и fib2) инициализируются значениями 0 и 1 соответственно, а затем в цикле каждый новый член вычисляется как сумма двух предыдущих членов (fib1 и fib2).
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
