Вопрос задан 13.03.2021 в 22:40.
Предмет Информатика.
Спрашивает Лильен Егор.
Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с
использованием case).Ответы на вопрос
Отвечает Гайдов Эмиль.
Var n,d:integer;
begin
write('Введите месяц :');
readln(n);
write('Введите день :');
readln(d);
n:=n mod 12;
case n mod 12 of
1: if d<=20 then writeln('Козерок') else writeln('Водолей');
2: if d<=21 then writeln('Водолей') else writeln('рыба');
3: if d<=21 then writeln('рыба') else writeln('овен');
4: if d<=21 then writeln('овен') else writeln('телец');
5: if d<=21 then writeln('телец') else writeln('близницы');
6: if d<=22 then writeln('близницы') else writeln('рак');
7: if d<=23 then writeln('рак') else writeln('лев');
8: if d<=24 then writeln('лев') else writeln('дева');
9: if d<=24 then writeln('дева') else writeln('весы');
10: if d<=24 then writeln('весы') else writeln('скорпион');
11: if d<=23 then writeln('скорпион') else writeln('стрелец');
12: if d<=22 then writeln('стрелец') else writeln('козерок');
end;
end.
//без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)
begin
write('Введите месяц :');
readln(n);
write('Введите день :');
readln(d);
n:=n mod 12;
case n mod 12 of
1: if d<=20 then writeln('Козерок') else writeln('Водолей');
2: if d<=21 then writeln('Водолей') else writeln('рыба');
3: if d<=21 then writeln('рыба') else writeln('овен');
4: if d<=21 then writeln('овен') else writeln('телец');
5: if d<=21 then writeln('телец') else writeln('близницы');
6: if d<=22 then writeln('близницы') else writeln('рак');
7: if d<=23 then writeln('рак') else writeln('лев');
8: if d<=24 then writeln('лев') else writeln('дева');
9: if d<=24 then writeln('дева') else writeln('весы');
10: if d<=24 then writeln('весы') else writeln('скорпион');
11: if d<=23 then writeln('скорпион') else writeln('стрелец');
12: if d<=22 then writeln('стрелец') else writeln('козерок');
end;
end.
//без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal ABC, которая определяет знак зодиака при вводе даты рождения с использованием оператора case:
pascalprogram ZodiacSign; var day, month: integer; begin writeln('Введите день рождения:'); readln(day); writeln('Введите месяц рождения:'); readln(month); case month of 1: // Январь if day < 20 then writeln('Ваш знак зодиака: Козерог') else writeln('Ваш знак зодиака: Водолей'); 2: // Февраль if day < 19 then writeln('Ваш знак зодиака: Водолей') else writeln('Ваш знак зодиака: Рыбы'); 3: // Март if day < 21 then writeln('Ваш знак зодиака: Рыбы') else writeln('Ваш знак зодиака: Овен'); 4: // Апрель if day < 20 then writeln('Ваш знак зодиака: Овен') else writeln('Ваш знак зодиака: Телец'); 5: // Май if day < 21 then writeln('Ваш знак зодиака: Телец') else writeln('Ваш знак зодиака: Близнецы'); 6: // Июнь if day < 21 then writeln('Ваш знак зодиака: Близнецы') else writeln('Ваш знак зодиака: Рак'); 7: // Июль if day < 23 then writeln('Ваш знак зодиака: Рак') else writeln('Ваш знак зодиака: Лев'); 8: // Август if day < 23 then writeln('Ваш знак зодиака: Лев') else writeln('Ваш знак зодиака: Дева'); 9: // Сентябрь if day < 23 then writeln('Ваш знак зодиака: Дева') else writeln('Ваш знак зодиака: Весы'); 10: // Октябрь if day < 23 then writeln('Ваш знак зодиака: Весы') else writeln('Ваш знак зодиака: Скорпион'); 11: // Ноябрь if day < 22 then writeln('Ваш знак зодиака: Скорпион') else writeln('Ваш знак зодиака: С
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
