Вопрос задан 13.03.2021 в 20:17.
Предмет Информатика.
Спрашивает Марамчин Вова.
Напишите программу для PascalABC срочно! Дано 5-значное число. Если оно палиндром, то вывести 0,
если нет-1Ответы на вопрос
Отвечает Синченкина Алина.
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
begin
var s:=ReadInteger('n=').ToString;
if s=s.Inverse then Writeln(0) else Writeln(1)
end.
begin
var s:=ReadInteger('n=').ToString;
if s=s.Inverse then Writeln(0) else Writeln(1)
end.
Отвечает Вороны Белые.
Var
i: string;
Begin
Writeln('Введите число');
Readln(i);
if ((i[1]=i[5]) and (i[2]=i[4])) then writeln('0') else writeln('1');
End.
i: string;
Begin
Writeln('Введите число');
Readln(i);
if ((i[1]=i[5]) and (i[2]=i[4])) then writeln('0') else writeln('1');
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на PascalABC, которая проверяет, является ли заданное 5-значное число палиндромом и выводит 0, если это так, и -1, если нет:
pascalprogram PalindromeCheck; var number, reversedNumber, originalNumber, remainder: integer; begin writeln('Введите 5-значное число:'); readln(number); originalNumber := number; reversedNumber := 0; // Переворачиваем число while number <> 0 do begin remainder := number mod 10; reversedNumber := reversedNumber * 10 + remainder; number := number div 10; end; // Проверяем, является ли число палиндромом if originalNumber = reversedNumber then writeln('0') else writeln('-1'); end.
Просто скопируйте этот код в среду разработки PascalABC и выполните его. Он запросит у вас ввести 5-значное число, а затем выведет 0, если число является палиндромом, или -1, если нет.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
