Вопрос задан 11.03.2021 в 00:44. Предмет Информатика. Спрашивает Ломейко Эля.

1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с

клавиатуры, пока не будет введено число 0. 2. Составить программу, которая вычисляет сколько лет можно выполнять план по отлову рыбы, если запасы рыбы составляют а тонн, ежегодный прирост рыбы 25%, ежегодный план отлова с тонн. PascalABC
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Котикова Ангелина.
1)
Program n1;
var sum,k,a: integer;
begin
sum:=0;
k:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
k:=k+1;
readln(a);
end;
write('сумма: ',sum,'; срзнач: ',sum/k);
end.
2)
Program n2;
var a,c,sum: real;
k: integer;
begin
k:=1;
readln(a,c);
sum:=a;
repeat
sum:=sum+a*0.25;
k:=k+1;
until sum>=c;
write(k);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке PascalABC, которая выполняет задачи, описанные в вашем вопросе:

  1. Программа для вычисления суммы и среднего арифметического чисел, вводимых с клавиатуры, пока не будет введено число 0:
pascal
program SumAndAverage; var number, sum: Integer; count: Integer; average: Real; begin sum := 0; count := 0; repeat Write('Введите число (для завершения введите 0): '); Readln(number); if number <> 0 then begin sum := sum + number; count := count + 1; end; until number = 0; if count > 0 then begin average := sum / count; Writeln('Сумма чисел: ', sum); Writeln('Среднее арифметическое: ', average:0:2); end else Writeln('Вы не ввели ни одного числа, программа завершена.'); Readln; end.
  1. Программа для вычисления количества лет, в течение которых можно выполнять план по отлову рыбы:
pascal
program FishingPlan; var fishStock: Real; annualGrowth: Real; fishingPlan: Real; years: Integer; begin Write('Введите начальное количество рыбы (в тоннах): '); Readln(fishStock); Write('Введите ежегодный прирост рыбы (в процентах): '); Readln(annualGrowth); Write('Введите ежегодный план отлова рыбы (в тоннах): '); Readln(fishingPlan); years := 0; while fishStock > 0 do begin fishStock := fishStock + (fishStock * annualGrowth / 100) - fishingPlan; if fishStock >= 0 then years := years + 1 else Break; end; Writeln('Можно выполнять план по отлову рыбы в течение ', years, ' лет.'); Readln; end.

Обратите внимание, что эти программы предназначены для языка PascalABC. Если вы хотите выполнить их на другом языке программирования, вам может потребоваться некоторая адаптация кода.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос