Написать программу в СИ, которая переворачивает массив. (Пример: 12345 ⇒ 54321)
Ответы на вопрос
#include "stdio.h"
#include "stdlib.h"
int main(){
int amount = 0;
int mas[amount];
int temp;
printf("Input capacity of massiv: "); scanf("%d",&amount);
for(int i = 0 ; i < amount; ++i){
printf("Element [%d] = ",i+1); scanf("%d",&mas[i]);
}
for(int i = 0; i < amount/2; ++i){
temp = mas[amount-i-1];
mas[amount-i-1] = mas[i];
mas[i] = temp;
}
for(int i = 0; i < amount; ++i){
printf("%d ", mas[i]);
}
system("pause");
return 0;
}
Конечно! Вот пример программы на языке C, которая переворачивает массив:
c#include <stdio.h>
void reverseArray(int arr[], int size) {
int start = 0;
int end = size - 1;
while (start < end) {
int temp = arr[start];
arr[start] = arr[end];
arr[end] = temp;
start++;
end--;
}
}
int main() {
int arr[] = {1, 2, 3, 4, 5};
int size = sizeof(arr) / sizeof(arr[0]);
printf("Original array: ");
for (int i = 0; i < size; i++) {
printf("%d ", arr[i]);
}
reverseArray(arr, size);
printf("\nReversed array: ");
for (int i = 0; i < size; i++) {
printf("%d ", arr[i]);
}
return 0;
}
В этой программе мы используем функцию reverseArray, которая принимает массив и его размер в качестве аргументов и переворачивает его, меняя местами элементы от начала массива с элементами с конца. Затем мы вызываем эту функцию в функции main для массива arr, выводим исходный массив и перевернутый массив на экран. Результат выполнения программы будет:
cOriginal array: 1 2 3 4 5
Reversed array: 5 4 3 2 1
Обратите внимание, что в программе я предполагаю, что размер массива известен и равен 5. Вы можете изменить содержимое массива и его размер в соответствии с вашими потребностями.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
