
Двумерные массивы. Задача: В прямоугольной таблице подсчитать произведение элементов в каждой
строке Составить программу на языке программирования Pascal

Ответы на вопрос

Ответ:
program ArrMul;
var
a: array [1..10, 1..10] of Real;
i, j: Integer;
p: Real;
begin
Randomize;
for i := 1 to 10 do begin
WriteLn;
for j := 1 to 10 do begin
a [i, j] := Random (10) + 1;
Write (a [i, j] :6 :2);
end;
end;
WriteLn;
for i := 1 to 10 do begin
p := 1;
for j := 1 to 10 do begin
p := p * a [i, j];
end;
WriteLn ('Строка ', i :2, p :20 :2);
end;
ReadLn;
end.
Объяснение:



Конечно! Вот пример программы на языке Pascal, которая вычисляет произведение элементов в каждой строке двумерного массива:
pascalprogram CalculateProduct; const MAX_ROWS = 5; MAX_COLS = 5; type Matrix = array[1..MAX_ROWS, 1..MAX_COLS] of Integer; procedure CalculateRowProduct(const matrix: Matrix; numRows, numCols: Integer); var i, j: Integer; rowProduct: Integer; begin for i := 1 to numRows do begin rowProduct := 1; // Инициализируем произведение единицей for j := 1 to numCols do begin rowProduct := rowProduct * matrix[i, j]; // Вычисляем произведение end; writeln('Произведение элементов в строке ', i, ': ', rowProduct); end; end; var matrix: Matrix; numRows, numCols, i, j: Integer; begin // Ввод размеров массива writeln('Введите количество строк:'); readln(numRows); writeln('Введите количество столбцов:'); readln(numCols); // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to numRows do begin for j := 1 to numCols do begin readln(matrix[i, j]); end; end; // Вычисление и вывод произведения элементов в каждой строке CalculateRowProduct(matrix, numRows, numCols); end.
Программа позволяет пользователю ввести размеры массива и его элементы. Затем она вызывает процедуру CalculateRowProduct
, которая вычисляет произведение элементов в каждой строке и выводит результаты на экран.
Обратите внимание, что в данном примере предполагается, что размеры массива не превышают MAX_ROWS
(максимальное количество строк) и MAX_COLS
(максимальное количество столбцов), которые определены как константы в программе. Вы можете изменить их значения в соответствии с вашими потребностями.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili