Вопрос задан 04.03.2021 в 23:21.
Предмет Информатика.
Спрашивает Чистякова Вера.
Написать программу в Паскаль 1) Дано число n, верно ли, что сумма его цифр четное число. 2)
Найдите сумму его цифр больше 5.Ответы на вопрос
Отвечает Мартынов Дима.
Зайди на сайт JavaRush! Там Всё про всё научат! Сам ответа не знаю так как не изучаем информатику, а на JavaRush Только начал!
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, который решает оба задания:
pascalprogram SumOfDigits; var n, digit, sum, sumGreaterThan5: integer; begin sum := 0; sumGreaterThan5 := 0; writeln('Введите число: '); readln(n); // Вычисляем сумму цифр числа while n > 0 do begin digit := n mod 10; // Получаем последнюю цифру числа sum := sum + digit; // Добавляем цифру к общей сумме // Проверяем, является ли цифра больше 5 if digit > 5 then sumGreaterThan5 := sumGreaterThan5 + digit; n := n div 10; // Удаляем последнюю цифру числа end; writeln('Сумма цифр числа: ', sum); // Проверяем, является ли сумма цифр четным числом if sum mod 2 = 0 then writeln('Сумма цифр является четным числом.') else writeln('Сумма цифр не является четным числом.'); writeln('Сумма цифр больше 5: ', sumGreaterThan5); readln; end.
Эта программа считывает число n с клавиатуры и затем вычисляет сумму его цифр. Она также находит сумму цифр, которые больше 5. Затем она проверяет, является ли сумма цифр четным числом, и выводит соответствующее сообщение. В конце она выводит сумму цифр, которые больше 5.
Обратите внимание, что в программе предполагается, что введенное число n является положительным целым числом.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
