Помогите составить программу в Паскаль по задаче: найти среднее арифметическое наибольшего и
наименьшего элементов в одномерном массиве Ответы на вопрос
===== PascalABC.NET =====
begin
var n := ReadInteger('n =');
var a := ArrRandom(n, -99, 99);
a.Println;
Println('Результат:', (a.Max + a.Min) / 2)
end.
===== Turbo Pascal =====
program abcd;
uses Crt;
const
nn = 100;
var
i, n, max, min: integer;
a: array[1..nn] of integer;
begin
ClrScr;
Write('n = ');
Readln(n);
Randomize;
max := -32768;
min := 32767;
for i := 1 to n do
begin
a[i] := Random(199) - 99;
Write(a[i], ' ');
if a[i] > max then
max := a[i]
else if a[i] < min then
min := a[i]
end;
Writeln;
Writeln('Результат: ', (max + min) / 2);
ReadKey
end.
Конечно, я могу помочь вам составить программу на языке Паскаль для решения данной задачи. Вот пример программы:
pascalprogram AverageMinMax; const MAX_SIZE = 100; var arr: array[1..MAX_SIZE] of Integer; n, i, min, max, sum: Integer; average: Real; begin // Ввод размера массива writeln('Введите размер массива (не более ', MAX_SIZE, '): '); readln(n); // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to n do begin write('arr[', i, '] = '); readln(arr[i]); end; // Нахождение минимального и максимального элементов min := arr[1]; max := arr[1]; for i := 2 to n do begin if arr[i] < min then min := arr[i]; if arr[i] > max then max := arr[i]; end; // Нахождение суммы наименьшего и наибольшего элементов sum := min + max; // Нахождение среднего арифметического average := sum / 2; // Вывод результата writeln('Среднее арифметическое наибольшего и наименьшего элементов: ', average:0:2); end.
В этой программе мы используем переменную n для хранения размера массива и массив arr для хранения элементов. Мы просим пользователя ввести размер массива и элементы с клавиатуры.
Затем мы находим минимальный и максимальный элементы в цикле, проходясь по всем элементам массива. После этого находим сумму наименьшего и наибольшего элементов и находим среднее арифметическое путем деления суммы на 2.
Наконец, выводим полученное среднее арифметическое на экран.
Пожалуйста, обратите внимание, что я предоставил вам программу на основе языка Паскаль, но она может быть немного изменена в зависимости от вашей среды разработки или конкретных требований задачи.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
