Вопрос задан 02.03.2021 в 03:14.
Предмет Информатика.
Спрашивает Басиева Эвелина.
Напишите программу в паскале: Дано 2 строки. Сосчитать количество символов в первой строке,
которых нет во второй.Ответы на вопрос
Отвечает Канаева Катя.
Var
s1,s2 : String;
n,i : Integer;
Begin
n:=0;
Readln(s1);
Readln(s2);
For i:=1 to Length(s1) do If Pos(s1[i],s2)=0 then Inc(n);
Writeln(n);
end.
s1,s2 : String;
n,i : Integer;
Begin
n:=0;
Readln(s1);
Readln(s2);
For i:=1 to Length(s1) do If Pos(s1[i],s2)=0 then Inc(n);
Writeln(n);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, который выполняет подсчет количества символов в первой строке, которых нет во второй:
pascalprogram CountDifferentChars; var str1, str2: string; count: integer; i: integer; j: integer; found: boolean; begin writeln('Введите первую строку:'); readln(str1); writeln('Введите вторую строку:'); readln(str2); count := 0; for i := 1 to Length(str1) do begin found := False; for j := 1 to Length(str2) do begin if str1[i] = str2[j] then begin found := True; break; end; end; if not found then Inc(count); end; writeln('Количество символов в первой строке, которых нет во второй:', count); readln; end.
Программа запрашивает у пользователя две строки и затем считает количество символов в первой строке, которых нет во второй. Результат выводится на экран.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
