Вопрос задан 28.02.2021 в 16:25.
Предмет Информатика.
Спрашивает Павлик Женя.
напишите программу(паскаль) запрашивает с клавиатуры у пользователя размер хищений (р.), определяет
и выводит на экран масштаб в соответствии с принятой классификацией (например, если размер хищений меньше 100 р. –«мелкий», от 100 до 1000 – «крупный», свыше 1000 – «особо крупный»Ответы на вопрос
Отвечает Соловьев Илья.
//PascalABC.NET 3.2 сборка 1318
Var
a:real;
begin
readln(a);
if a<100 then
writeln('Мелкий')
else
if (a>=100) and (a<1000) then
writeln('Крупный')
else
writeln('Особо крупный');
end.
Пример ввода:
1001
Пример вывода:
Особо крупный
Var
a:real;
begin
readln(a);
if a<100 then
writeln('Мелкий')
else
if (a>=100) and (a<1000) then
writeln('Крупный')
else
writeln('Особо крупный');
end.
Пример ввода:
1001
Пример вывода:
Особо крупный
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая выполняет описанную вами задачу:
pascalprogram РазмерХищений; var размер: integer; begin writeln('Введите размер хищений:'); readln(размер); if размер < 100 then writeln('Мелкий') else if (размер >= 100) and (размер <= 1000) then writeln('Крупный') else writeln('Особо крупный'); end.
В этой программе мы используем переменную размер для хранения введенного пользователем значения. Затем мы проверяем условия с помощью операторов if и else if для определения масштаба хищений. Результат выводится на экран с помощью оператора writeln.
Обратите внимание, что в этой программе предполагается, что пользователь вводит только целочисленные значения для размера хищений.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
