Вопрос задан 24.02.2021 в 01:14.
Предмет Информатика.
Спрашивает Жеребненко Олег.
Составить программу, которая определяет, какое из двух введенных с клавиатуры слов разной длины
более длинное, и выводит это слово. Паскаль абцОтветы на вопрос
Отвечает Узгенжанов Умарбек.
Program z567;
Var s_1,s_2:string; l,l_1:integer;
Begin
write('Введите 1-ое слово - '); readln(s_1);
write('Введите 2-ое слово - '); readln(s_2);
if (s_1.Length > s_2.Length) then writeln(s_1)
else writeln(s_2);
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Паскаль, которая сравнивает два слова, введенных с клавиатуры, и определяет, какое из них более длинное:
pascalprogram CompareWords; var word1, word2: string; begin writeln('Введите первое слово:'); readln(word1); writeln('Введите второе слово:'); readln(word2); if Length(word1) > Length(word2) then writeln('Первое слово "', word1, '" является более длинным.') else if Length(word2) > Length(word1) then writeln('Второе слово "', word2, '" является более длинным.') else writeln('Оба слова имеют одинаковую длину.'); readln; end.
После запуска программы вы сможете ввести два слова с клавиатуры, а затем программа определит, какое из них более длинное и выведет соответствующее сообщение.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
