Вопрос задан 23.02.2021 в 13:53.
Предмет Информатика.
Спрашивает Перцев Евгений.
составить программу на с++. вводим переменные ABCD . программа должна вывести количество переменных
быльше 0Ответы на вопрос
Отвечает Щербакова Ксюша.
Решение в прикреплении.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на C++, которая позволит вам ввести переменные ABCD и выведет количество переменных, больших нуля:
cpp#include <iostream>
int main() {
int A, B, C, D;
int count = 0;
std::cout << "Введите переменные A, B, C и D: ";
std::cin >> A >> B >> C >> D;
if (A > 0) {
count++;
}
if (B > 0) {
count++;
}
if (C > 0) {
count++;
}
if (D > 0) {
count++;
}
std::cout << "Количество переменных, больших нуля: " << count << std::endl;
return 0;
}
В этой программе мы используем четыре переменные A, B, C и D, чтобы пользователь мог ввести значения. Затем мы проверяем каждую переменную на больше нуля и увеличиваем счетчик count соответственно. В конце программы выводим количество переменных, больших нуля.
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
