Вопрос задан 19.02.2021 в 11:55.
Предмет Информатика.
Спрашивает Кравченко Наташа.
Помогите пожалуйста, нужно написать программу для Free Pascal Мама-ежиха принесла А грибов,
папа-ёж принес В грибов. В семье К маленьких ежат. Было решено поделить грибы на всех поровну, включая маму и папу. Если что-то останется, можно засушить на зиму. Сколько грибов достанется каждому?Ответы на вопрос
Отвечает Бобыкина Алёна.
var a,b,k:integer;
begin
writeln('a, b, k:');
readln(a,b,k);
writeln('Каждый получит по ', (a+b) div (k+2),' гр.');
end.
Пример:
a, b, k:
15 20 4
Каждый получит по 5 гр.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на языке программирования Free Pascal для решения этой задачи. Вот пример программы:
pascalprogram DivideMushrooms; var A, B, K, totalMushrooms, mushroomsPerEjat, remainingMushrooms: integer; begin writeln('Введите количество грибов, принесенных мамой-ежихой (А): '); readln(A); writeln('Введите количество грибов, принесенных папой-ёжем (B): '); readln(B); writeln('Введите количество маленьких ежат (K): '); readln(K); totalMushrooms := A + B; // Общее количество грибов mushroomsPerEjat := totalMushrooms div (K + 2); // Грибы на каждого ежат и родителей remainingMushrooms := totalMushrooms mod (K + 2); // Оставшиеся грибы writeln('Каждому ежату и родителям достанется ', mushroomsPerEjat, ' грибов.'); if remainingMushrooms > 0 then writeln('Остаток грибов: ', remainingMushrooms, '. Можно засушить на зиму.') else writeln('Нет остатка грибов. Ничего не нужно засушивать.'); readln; end.
Программа запрашивает количество грибов, принесенных мамой и папой, а также количество маленьких ежат. Затем она вычисляет количество грибов на каждого ежату и родителям (при условии, что грибы делятся поровну) и определяет остаток грибов. Результат выводится на экран.
Помните, что язык программирования Pascal чувствителен к регистру, поэтому убедитесь, что код написан с учетом этого.
Топ вопросов за вчера в категории Информатика
Информатика 19
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
