Вопрос задан 19.02.2021 в 10:39.
Предмет Информатика.
Спрашивает Сергеева Валентина.
написать программу,находящую скорость или время или пройденное расстояние в зависимости от запроса
пользователя.(авс паскаль)Ответы на вопрос
Отвечает Козлова Света.
Program fgg;
var
x: String[10];
t, v, s: Real;
begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
var
x: String[10];
t, v, s: Real;
begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal (Delphi), которая запрашивает у пользователя входные данные и рассчитывает скорость, время или пройденное расстояние в зависимости от запроса пользователя:
pascalprogram Calculator; var choice: integer; distance, time, speed: real; begin writeln('Выберите, что вы хотите вычислить:'); writeln('1. Скорость'); writeln('2. Время'); writeln('3. Пройденное расстояние'); readln(choice); case choice of 1: begin writeln('Введите пройденное расстояние (в километрах): '); readln(distance); writeln('Введите время (в часах): '); readln(time); speed := distance / time; writeln('Скорость: ', speed:0:2, ' км/ч'); end; 2: begin writeln('Введите пройденное расстояние (в километрах): '); readln(distance); writeln('Введите скорость (в км/ч): '); readln(speed); time := distance / speed; writeln('Время: ', time:0:2, ' ч'); end; 3: begin writeln('Введите время (в часах): '); readln(time); writeln('Введите скорость (в км/ч): '); readln(speed); distance := time * speed; writeln('Пройденное расстояние: ', distance:0:2, ' км'); end; else writeln('Неверный выбор!'); end; readln; end.
Эта программа предлагает пользователю выбрать, что он хочет вычислить (скорость, время или пройденное расстояние). Затем она запрашивает необходимые данные от пользователя и выполняет соответствующие вычисления. Результат выводится на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
