Помогите составить программу в Pascal ABC по этим числам 18082000 в OnVector
Ответы на вопрос
Program Masha;
uses Drawman;
begin
Field(20,20);
OnVector(1,8);
PenDown;
OnVector(0,8);
OnVector(2,0);
OnVector(0,0);
end.
Конечная цель программы вам не ясна. Однако, если вы хотите создать программу на языке Pascal ABC, которая будет работать с числом 18082000 и использовать векторы (OnVector), вот пример программы, которая создает вектор из цифр числа 18082000:
pascalprogram OnVectorExample; uses OnVector; const Number = 18082000; var i: integer; digits: TOnVector; begin digits := TOnVector.Create; // Создание вектора // Разложение числа на цифры и добавление их в вектор while Number > 0 do begin digits.Add(Number mod 10); Number := Number div 10; end; // Вывод цифр из вектора writeln('Цифры числа:'); for i := digits.Size - 1 downto 0 do writeln(digits.Get(i)); digits.Free; // Освобождение памяти, занятой вектором end.
Программа использует модуль OnVector для работы с векторами. Она разбивает число 18082000 на отдельные цифры и добавляет их в вектор. Затем она выводит цифры из вектора в обратном порядке (так как они были добавлены в обратном порядке).
Пожалуйста, учтите, что Pascal ABC является диалектом языка Pascal, который имеет свои особенности и расширения. Возможно, вам потребуется настроить свою среду разработки для поддержки модуля OnVector или использовать альтернативные способы работы с векторами в Pascal ABC, если он не поддерживает данный модуль по умолчанию.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
