Вопрос задан 14.02.2021 в 01:44.
Предмет Информатика.
Спрашивает Леонардыч Евгений.
Составить программу, спрашивающую у ученика его отметку по информатике и реагирующую на нее
подходящим текстом 1-4 - Кошмар! 5-6 - Неважно. 7-8 - Неплохо . 9-10 - Молодец!Ответы на вопрос
Отвечает Ильичёва Анна.
Program n1;
var m: integer;
begin
readln(m);
case m of
1..4: writeln('кошмар!');
5..6: writeln('неважно.');
7..8: writeln('неплохо.');
9..10: writeln('молодец!');
end;
end.
var m: integer;
begin
readln(m);
case m of
1..4: writeln('кошмар!');
5..6: writeln('неважно.');
7..8: writeln('неплохо.');
9..10: writeln('молодец!');
end;
end.
Отвечает Билов Игорь.
Program z213124;
var a:integer;
begin
write ('введите ваш балл' );
readln (a);
if (a>=1) and (a<=4) then write ('кошмар!');
if (a>=5) and (a<=6) then write ('неважно');
if (a>=7) and (a<=8) then write ('неплохо');
if (a>=9) and (a<=10) then write ('молодец!');
end.
var a:integer;
begin
write ('введите ваш балл' );
readln (a);
if (a>=1) and (a<=4) then write ('кошмар!');
if (a>=5) and (a<=6) then write ('неважно');
if (a>=7) and (a<=8) then write ('неплохо');
if (a>=9) and (a<=10) then write ('молодец!');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Python, которая будет спрашивать у ученика его отметку по информатике и реагировать на нее подходящим текстом:
pythonmark = int(input("Введите свою отметку по информатике: "))
if mark >= 1 and mark <= 4:
print("Кошмар!")
elif mark >= 5 and mark <= 6:
print("Неважно.")
elif mark >= 7 and mark <= 8:
print("Неплохо.")
elif mark >= 9 and mark <= 10:
print("Молодец!")
else:
print("Некорректная отметка. Пожалуйста, введите отметку от 1 до 10.")
Программа будет запрашивать у ученика его отметку по информатике, а затем сравнивать ее с определенными диапазонами для выдачи соответствующего текстового сообщения. Если ученик введет отметку, не входящую в диапазон от 1 до 10, программа выведет сообщение о некорректной отметке и попросит ввести отметку снова.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
