 
Вопрос задан 11.02.2021 в 22:53.
Предмет Информатика.
Спрашивает Курганский Егор.
Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Вітвіцький Тарас.
                
                   Program prog;              
uses crt;
var x,y:integer;
begin
clrscr;
write ('x = ');
readln(x);
while abs(x)>0 do begin
if abs(x mod 10)>y then y:= abs(x mod 10);
x:= x div 10;
end;
writeln('Наибольшая цифра чсла = ', y);
               
end.
              
              
                                        uses crt;
var x,y:integer;
begin
clrscr;
write ('x = ');
readln(x);
while abs(x)>0 do begin
if abs(x mod 10)>y then y:= abs(x mod 10);
x:= x div 10;
end;
writeln('Наибольшая цифра чсла = ', y);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно! Вот пример программы на языке Паскаль для определения наибольшей цифры в записи данного натурального числа:
pascalprogram MaxDigit; var number, digit, maxDigit: Integer; begin // Ввод числа Write('Введите натуральное число: '); Readln(number); // Инициализация переменных maxDigit := 0; // Поиск наибольшей цифры while number > 0 do begin digit := number mod 10; // Получаем последнюю цифру числа if digit > maxDigit then maxDigit := digit; number := number div 10; // Удаляем последнюю цифру числа end; // Вывод результата Writeln('Наибольшая цифра: ', maxDigit); // Завершение программы Readln; end.
Программа сначала запрашивает у пользователя ввод натурального числа. Затем она инициализирует переменную maxDigit значением 0. В цикле while программа получает последнюю цифру числа с помощью операции деления по модулю и сравнивает её со значением maxDigit. Если текущая цифра больше, то maxDigit обновляется. Затем программа удаляет последнюю цифру числа с помощью операции деления нацело. Цикл продолжается, пока число не станет равным 0. В конце программа выводит наибольшую цифру на экран.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			