Вопрос задан 11.02.2021 в 22:29.
Предмет Информатика.
Спрашивает Боярчук Алина.
Даны два действительных числа Составьте программу которая меньшее из них занимает их полусуммой а
большее произведением.Ответы на вопрос
Отвечает Дяденчук Діма.
#include <iostream>
int main() {
double a, b, t;
std::cin >> a >> b;
if( a > b) {
t = a;
a = a * b;
b = (t + b) / 2;
} else {
t = a;
a = (a + b) / 2;
b = t * b;
}
std::cout << a << " " << b << std::endl;
}
int main() {
double a, b, t;
std::cin >> a >> b;
if( a > b) {
t = a;
a = a * b;
b = (t + b) / 2;
} else {
t = a;
a = (a + b) / 2;
b = t * b;
}
std::cout << a << " " << b << std::endl;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Python, которая выполняет указанную задачу:
pythona = float(input("Введите первое число: "))
b = float(input("Введите второе число: "))
half_sum = (a + b) / 2
product = a * b
if a < b:
smaller = a
larger = b
else:
smaller = b
larger = a
print("Меньшее число, занимающее полусумму:", smaller)
print("Большее число, занимающее произведение:", larger)
Программа сначала запрашивает у пользователя два действительных числа. Затем она вычисляет полусумму и произведение этих чисел. Затем с помощью условного оператора (if-else) программа определяет, какое число меньше, а какое больше, и выводит соответствующие результаты на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
