Вопрос задан 25.01.2021 в 10:36.
Предмет Информатика.
Спрашивает Куроптев Илья.
Составьте программу по которой компьютер 10 раз запросит ввод любых чисел и в результате выведет
среднее арифметическое значение введённых чисел массив не использует сделайте три варианта программы используя операторы цикла в while repet и for номер 2 и 4 пожалуйста помогите !
Ответы на вопрос
Отвечает Антонова Настя.
1.
program ddg2;
var
i, j, k: Integer;
begin
repeat
begin
WriteLn('число: ');
ReadLn(i);
k := k + 1;
j := j + i;
end
until k = 10;
WriteLn('Среднее арифметическое=', j / 10);
end.
2.
program ddg1;
var i,j,k:Integer;
begin
while k<>10 do begin
WriteLn('число: ');
ReadLn(i);
k:=k+1;
j:=j+i;
end;
WriteLn('Среднее арифметическое=',j/10);
end.
3.
program ddg;
var
i, j: Integer;
begin
for i := 1 to 10 do
begin
WriteLn('Введите число:');
readln(i);
end;
j := j + i;
WriteLn('Среднее арифметическое = ', j / 10);
end.
4. Таблица умножения:
program fgg;
var
n, m: integer;
begin
for n := 1 to 10 do
for m := 0 to 10 do
WriteLn(n, '*', m, '=', n * m);
end.
program ddg2;
var
i, j, k: Integer;
begin
repeat
begin
WriteLn('число: ');
ReadLn(i);
k := k + 1;
j := j + i;
end
until k = 10;
WriteLn('Среднее арифметическое=', j / 10);
end.
2.
program ddg1;
var i,j,k:Integer;
begin
while k<>10 do begin
WriteLn('число: ');
ReadLn(i);
k:=k+1;
j:=j+i;
end;
WriteLn('Среднее арифметическое=',j/10);
end.
3.
program ddg;
var
i, j: Integer;
begin
for i := 1 to 10 do
begin
WriteLn('Введите число:');
readln(i);
end;
j := j + i;
WriteLn('Среднее арифметическое = ', j / 10);
end.
4. Таблица умножения:
program fgg;
var
n, m: integer;
begin
for n := 1 to 10 do
for m := 0 to 10 do
WriteLn(n, '*', m, '=', n * m);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
