
Вопрос задан 15.06.2018 в 20:19.
Предмет Информатика.
Спрашивает Афанасьева Екатерина.
Задание по информатике 10 класс напишите программу, по которой из текстового файла с именем
kvur.txt будут прочитаны три числа- a,b,c коэффициенты квадратного уравнения, затем будут вычеслены корни этого уравнения и выведены на экран и в текстовой файл korni.txt.

Ответы на вопрос

Отвечает Марчук Паша.
//Код Pascal:
Var
f:text;
a,b,c,D:real;
Begin
Assign(f,'kvur.txt');
Reset(f);
ReadLn(f,a,b,c);
Close(f);
Assign(f,'korni.txt');
Rewrite(f);
D:=b*b-4*a*c;
c:=(-b-Sqrt(D))/(2*a);
a:=(-b+Sqrt(D))/(2*a);
if D >= 0 then
Begin
WriteLn(c,' ',a);
WriteLn(f,c,' ',a)
End
else
Begin
WriteLn('Действительных корней нет.');
WriteLn(f,'Действительных корней нет.')
End;
Close(f);
ReadLn;
End.
Для корректной работы программы файлы должны находиться в одной папке с программой.



Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili