Вопрос задан 16.01.2021 в 05:16.
Предмет Информатика.
Спрашивает Фатхиев Айрат.
Составить программу,которая в зависимости от порядкового номера месяца выводит на экран количество
дней в этом месяце.Рассмотреть два случая: 1.год високосный. 2.год не является високоснымОтветы на вопрос
Отвечает Жуман Улан.
Program G;
Uses Crt;
Var count, num, ch: integer;
Begin
ClrScr;
Writeln('Год високосный? 1 - да, 0 - нет');
Readln(Ch);
If ch=1 then
Begin
Writeln('Введите номер месяца');
Readln(num);
Сase num of
1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');
4, 6, 9, 11: writeln('В месяце 30 дней.');
2: writeln('В месяце 29 дней');
else writeln('Некорректный ввод данных')
End;
End
Else if ch=0 then
Begin
Writeln('Введите номер месяца');
Readln(num);
Сase num of
1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');
4, 6, 9, 11: writeln('В месяце 30 дней.');
2: writeln('В месяце 28 дней');
else writeln('Некорректный ввод данных')
End;
End
Else writeln('Некорректный ввод данных');
Readln;
End.
Uses Crt;
Var count, num, ch: integer;
Begin
ClrScr;
Writeln('Год високосный? 1 - да, 0 - нет');
Readln(Ch);
If ch=1 then
Begin
Writeln('Введите номер месяца');
Readln(num);
Сase num of
1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');
4, 6, 9, 11: writeln('В месяце 30 дней.');
2: writeln('В месяце 29 дней');
else writeln('Некорректный ввод данных')
End;
End
Else if ch=0 then
Begin
Writeln('Введите номер месяца');
Readln(num);
Сase num of
1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.');
4, 6, 9, 11: writeln('В месяце 30 дней.');
2: writeln('В месяце 28 дней');
else writeln('Некорректный ввод данных')
End;
End
Else writeln('Некорректный ввод данных');
Readln;
End.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
