Вопрос задан 01.11.2020 в 14:25.
Предмет Информатика.
Спрашивает Голубева Алина.
Составить программу суммы только четных чисел (числа целые) из последовательно вводимых чисел,
можно осуществить ввод заказного количества чисел. Помогите, отдаю максимум баллов.
Ответы на вопрос
Отвечает Александрова Александра.
Var a,n,s,i:integer;
begin
write('n=');readln(n);
s:=0;
for i:=1 to n do
begin
write('a',i,'='); readln(a);
if a mod 2 =0 then s:=s+a;
end;
writeln('s=',s)
end.
Пример работы программы:
n=5
a1=15
a2=8
a3=7
a4=6
a5=9
s=14
begin
write('n=');readln(n);
s:=0;
for i:=1 to n do
begin
write('a',i,'='); readln(a);
if a mod 2 =0 then s:=s+a;
end;
writeln('s=',s)
end.
Пример работы программы:
n=5
a1=15
a2=8
a3=7
a4=6
a5=9
s=14
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
